Finwise Unresponsive

Incident Report for Finwise Status

Resolved

The incident has been resolved. FW is back online
Posted Apr 01, 2026 - 12:29 SAST

Identified

We are aware that Finwise is currently not responding. Our developers are working on a solution.
Posted Apr 01, 2026 - 12:08 SAST
This incident affected: Finwise Web.