Standard Bank - Error with new Debicheck mandates
Incident Report for Finwise Status
Resolved
Standard Bank has advised the issue should be resolved. Please let us know if you still experience issues with new Standard Bank mandates.
Posted Dec 13, 2023 - 11:23 SAST
Identified
New mandate registrations on Standard Bank clients are returning errors. The issue appears to be on Standard Bank side.
Posted Dec 13, 2023 - 09:18 SAST
This incident affected: Finwise Web.