Delayed Debicheck responses

Incident Report for Finwise Status

Resolved

This incident has been resolved.
Posted Nov 25, 2023 - 08:07 SAST

Identified

Debicheck mandate and collections responses are delayed.
We are attending to the issue, and hope to have it resolved soonest.
Posted Nov 24, 2023 - 13:04 SAST
This incident affected: Finwise Web.