Finwise non responsive

Incident Report for Finwise Status

Resolved

This incident has been resolved
Posted Jul 01, 2025 - 12:46 SAST

Identified

We are aware of the system being non responsive, or displaying Error 502. Our developers are attending to this with top priority.
Posted Jul 01, 2025 - 11:51 SAST
This incident affected: Finwise Web.