New Debicheck mandate errors

Incident Report for Finwise Status

Resolved

The incident should be resolved. Please contact us if you are still experiencing issues with new mandates.
Posted Mar 26, 2025 - 10:11 SAST

Identified

We will be implementing a fix for the Debicheck errors at 10am this morning. Users may temporarily be logged out, or experience a loss in connection.
Posted Mar 26, 2025 - 09:50 SAST

Investigating

We are aware of the errors on new Debicheck mandates, and our IT team are working to resolve this soonest.
Posted Mar 26, 2025 - 08:33 SAST
This incident affected: Finwise Web.