Finwise unresponsive

Incident Report for Finwise Status

Resolved

Finwise is back online. Please refresh if needed.
Posted Mar 27, 2026 - 13:15 SAST

Identified

We are aware that Finwise is currently not responding. Our developers are working on a solution.
Posted Mar 27, 2026 - 13:03 SAST
This incident affected: Finwise Web.