Delayed Debicheck response
Incident Report for Finwise Status
Resolved
RMB confirmed that responses are being processed as normal
Posted Nov 19, 2024 - 11:47 SAST
Identified
RMB is experiencing a delay in new Debicheck mandate response files.
You may continue to load new files, please just allow additional time for the responses to update.
Posted Nov 19, 2024 - 10:02 SAST
This incident affected: Finwise Web.