Debicheck response delays
Incident Report for Finwise Status
Resolved
This incident has been resolved.
Posted Dec 01, 2023 - 07:46 SAST
Monitoring
Due to high volumes, we have noticed some delays in responses on our Debicheck files. This is being monitored, and all files will be updated ASAP.
Posted Nov 30, 2023 - 10:16 SAST
This incident affected: Finwise Web.