Tyme Bank Debicheck Mandates
Incident Report for Finwise Status
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 16:42 SAST
Identified
New mandate registrations for Tyme Bank accounts are currently failing. Tyme Bank is working on the issue, but no ETA have been provided.
Posted Apr 11, 2024 - 09:12 SAST
This incident affected: Finwise Web.