Debicheck Transactions

Incident Report for Finwise Status

Resolved

This issue has been resolved
Posted Nov 22, 2023 - 15:30 SAST

Investigating

We are aware of new collections not displayed on the Applicants Debicheck transactions. The issue is being investigated.
Posted Nov 22, 2023 - 13:16 SAST
This incident affected: Finwise Web.