DEBICHECK
Incident Report for Finwise Status
Resolved
This issue has been resolved
Posted Jul 22, 2021 - 13:28 SAST
Identified
Please note we are investigating the Debichecks which display cancelled, while the mandates are still Active.
This appears to be a display issue and will be updated soon
Posted Jul 22, 2021 - 11:39 SAST
This incident affected: Finwise Web.